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Welcome
Introduction
Welcome and thank you for using version v1.0.3 of the Pharos Dynamic Media Manager software. This is the first
public release of this software.

Platforms
Pharos Dynamic Media Manager is designed to run on a PC running Microsoft Windows 7, Vista or XP (SP2+) or an
Apple Mac running OS X (10.5.x or later - Intel only). As the application is of a highly graphical nature a large monitor
is recommended (800x600 minimum) .

Help Overview
The Help is split into four major sections: Quick Start, Reference, Troubleshooting, and Appendices.
Those of you experimenting with the software for the first time should work through the Quick Start guide to familiarise yourself with the basics of the software. The Reference section then gives detailed descriptions of every
aspect of the software. The Troubleshooting section provides help to resolve any problems while the Appendices provide additional useful resources.

Help Help
This is the PDF version of the online Help and it is available in various formats for printing. The online version, which
has the advantage of being fully searchable, can be opened from within Dynamic Media Manager by clicking the
help button on the main toolbar.

Support
As with all successful control products, support is crucial and the team at Pharos will do everything possible to
ensure that your project is a success. Please do not hesitate to contact us with your questions, bug reports and suggestions at:
T: +44-(0)20-7471-9229
E: support@pharoscontrols.com
Please also visit our website to keep up to date with the latest product news and software releases: www.pharoscontrols.com.
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What's New in v1.0.3

What's New in v1.0.3
l
l

Multithreading support for exporting media
New web help
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Overview
Pharos Dynamic Media Manager is a tool to program media sequences onto media slots that have been imported
from one or more Pharos Designer projects. Media slots are programmed onto pixel matrices in Pharos Designer to
act as placeholders for media that will be generated after the Designer project has been uploaded to Pharos Controllers. By uploading media sequences created by Pharos Dynamic Media Manager to Pharos Controllers, you can
change the media content of timelines without needing to open or modify the Designer project file.
The media slots from multiple Pharos Designer projects can be imported into one Pharos Dynamic Media Manager
project, which allows the media for large, multi-project installations to be managed simultaneously.
Pharos Installation Manager can be used to quickly and easily upload the media exported from Dynamic Media Manager to the correct Pharos Controllers, either across a local network or across the Internet.
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User Interface

User Interface
The software has been designed to present a consistent graphical user interface and so it is worth familiarising yourself with the layout of the main window before proceeding further:

Main toolbar
The buttons on the left of the main toolbar provide overall control of your Dynamic Media Manager project. Create
new projects, open existing projects and save your work using the file management buttons. Use the Undo/Redo buttons to step backwards and forwards through operations that affect your project. The Import button allows you to add
media slots to your project, as exported from a Pharos Designer project file, and the Export button generates the files
needed for each Controller to be able to play back your media slot programming.

Media Slot Browser
Any media slots that have been imported into your Dynamic Media Manager project are listed here. Media slots from
different Designer projects with the same name will only be listed once. The length of each media slot, as configured
when the media slot was created in Designer, is also listed. To begin editing the programming for a media slot, click
it in this browser to select it. Click here to find out more about managing media slots.

Designer Project Control
The drop-down list can be used to filter the media slots displayed in the media slot browser by Designer project. All
the media slots imported from a Designer project can be removed from the Dynamic Media Manager project by clicking the

button.
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Media Preset Library
Create new lighting presets from the built-in matrix effects, or import your own video and images. You can also
create custom presets using Lua scripts. Click here to find out more about media presets.

Media Slot Timeline Editor
The programming for the currently selected media slot is displayed here. Elements can be reordered by drag & drop.
Transitions can be edited by clicking the
button. Media presets are added to the timeline by dragging them from
the media preset library. The total length of the programming is displayed to the right of the media slot timeline editor.

-8-

Keyboard shortcuts

Keyboard shortcuts
For ease and speed of use various keyboard keys map to application commands:
● F1

Launch the online help.

● Ctrl + N

New project.

● Ctrl + O

Open project.

● Ctrl + S

Save project.

● Ctrl + Z

Undo the last operation.

● Ctrl + Shift + Z
Redo the last operation to be undone.
● Ctrl + Y

Notes for Macintosh users
Pharos Dynamic Media Manager makes a good deal of use of the two button mouse with right-click being used to
invoke context-sensitive menus. As the majority of Mac users have only a single button mouse they must hold Ctrl
while clicking to get this functionality. Furthermore Macs have an Command key that serves as the alternative to the
Windows Ctrl key. Shift and Alt work as described for Windows.
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Project Files
Pharos Dynamic Media Manager projects are saved with the file extension ".dmm".

Creating a new project
Click
or press Ctrl+N. You will be prompted to choose a location to save your new project and then a blank
project will be created with no media slots or media presets.

Opening a project
Click
or press Ctrl+O. You will be prompted to choose an existing .dmm file to load. As the project loads,
Dynamic Media Manager checks if all the media files referenced in the project exist. If not, you will be prompted to
locate these files.

Saving a project
Click

or press Ctrl+S.

To save to a different file or to export your project complete with all your media files, click
and choose either
Save As or Export Project. You will be prompted to choose a new location to save to. After Save As, subsequent
saves will go to the new file.

- 10 -

Media Slots & Pixel Matrices

Media Slots & Pixel Matrices
Importing Media Slots & Pixel Matrices
Pharos Designer exports media slots to files with extension ".pmm". These files contain information about the media
slots and the pixel matrices onto which they're programmed. To generate a .pmm file in Designer, go to File > Export
for Media Manager.
Click

. You will be prompted to choose a .pmm file to import from.

Imported media slots will appear in the media slot browser on the left of the application window. Their name and
length is shown.
If you make changes to your Designer project, simply go to File > Export for Media Manager in Designer again and
import the .pmm file into your existing Dynamic Media Manager project. You media slots will be updated with the
new details.

Filtering Media Slots
The media slots in the media slot browser can be filtered by the Designer project(s) in which they're used.
Select a Designer project from the drop-down list underneath the media slot browser. Only the media slots used by
the selected Designer project will be shown in the media slot browser.

Removing Media Slots & Pixel Matrices
Media slots and pixel matrices cannot be removed individually, but all the media slots and pixel matrices imported
from a Designer project can be removed together.
Select a Designer project from the drop-down list underneath the media slot browser, then click . All the pixel
matrices imported from the Designer project will be removed, along with any media slots that aren't referenced by
any other imported Designer project(s).
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Media Presets
Media presets are the building blocks of media slot programming. You can create media presets from built-in matrix
effects, existing video and image files, or code your own using Lua scripts.

2D Matrix Presets
Creating a 2D Matrix Preset
Select the 2D Matrix tab on the right of the application window. Click Create New. The 2D Matrix preset editing
dialog will appear.

- 12 -

Media Presets

Click OK when you've finished setting up your 2D matrix preset. The new 2D matrix preset will appear in the 2D
matrix preset library as a thumbnail image and the name of the effect.

Renaming a 2D Matrix Preset
Double-click a 2D matrix preset in the library and type a new name.

Editing a 2D Matrix Preset
To modify an existing 2D matrix preset, select the 2D matrix preset in the library and click Edit or right-click the 2D
matrix preset and select Edit. The 2D matrix editing dialog will appear. Click OK when you've finished editing, or
Cancel to discard your changes.
Any media slots that use this 2D matrix preset will now use the new settings.

Deleting a 2D Matrix Preset
Select the 2D matrix prest in the library and click Delete or right-click the 2D matrix preset and select Delete.

Video Presets
Creating a Video Preset
Select the Video tab on the right of the application window. Click Create New . You will be prompted to choose an
existing video file. The new video preset will appear in the video preset library as a thumbnail image and its file name.

Renaming a Video Preset
Double-click a video preset in the library and type a new name.

Changing a Video Preset
To change the source file of an existing video preset, select the video preset in the library and click Locate or rightclick the video preset and select Locate. You will be prompted to select an existing video file.
Any media slots that use this video preset will now use the new video source file.

Deleting a Video Preset
Select the video preset in the library and click Delete or right-click the video preset and select Delete.

Image Presets
Creating an Image Preset
Select the Image tab on the right of the application window. Click Create New . You will be prompted to choose an
existing image file. The new image preset will appear in the image preset library as a thumbnail image and its file
name.
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Renaming an Image Preset
Double-click an image preset in the library and type a new name.

Changing an Image Preset
To change the source file of an existing image preset, select the image preset in the library and click Locate or rightclick the image preset and select Locate. You will be prompted to select an existing image file.
Any media slots that use this image preset will now use the new image source file.

Deleting an Image Preset
Select the image preset in the library and click Delete or right-click the image preset and select Delete.

Custom Presets
Creating a Custom Preset
Select the Custom tab on the right of the application window. Click Create New. The custom preset editing dialog
will appear.

- 14 -

Media Presets

For help with writing custom presets for Pharos in Lua, please read the Custom Preset Programming Guide appendix in the Pharos Designer help.
Click OK when you've finished writing and configuring your custom preset. The new custom preset will appear in the
custom preset library as a thumbnail image.

Renaming a Custom Preset
Double-click a custom preset in the library and type a new name.

Editing a Custom Preset
To modify an existing custom preset, select the custom preset in the library and click Edit or right-click the 2D
matrix preset and select Edit. The custom preset editing dialog will appear. Click OK when you've finished editing,
or Cancel to discard your changes.
Any media slots that use this custom preset will now use the new settings.
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Deleting a Custom Preset
Select the custom prest in the library and click Delete or right-click the custom preset and select Delete.
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Programming

Programming
Media presets can be programmed onto the selected media slot. Transitions can be set up between media presets.
If the total length of programming on a media slot is less than the length of the media slot then the content will loop
when played back by Controllers. If the total length of programming on a media slot is greater than the length of the
media slot then some cropping will occur.

Adding a Media Preset to a Media Slot
l
l

Select the media slot to program from the media slot browser on the left of the application window.
Click and drag a media preset from the media preset library and drop it onto the media slot timeline at the bottom of the application window.

Reordering Media Presets on a Media Slot Timeline
Click and drag a media preset on the timeline of a media slot to change its position in the timeline.

Editing the Length of a Media Preset
Enter the new length into the length editor of the media preset on the media slot timeline. If the length is longer than
the length of the media preset source then the media preset will loop.
Click
value.

next to the length editor of the media preset on the media slot timeline to reset the length to the default

Editing the Transition of a Media Preset
Click

within the media preset on the media slot timeline. The transition editor dialog will appear.

Transition Properties
l
l
l
l

Time: the duration of the transition. This cannot be more than the length of the media preset.
Type: how the media presets should blend into each other.
Spread: how many pixels should be involved in the transition at once.
Angle: the start angle for the transition (in degrees).
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Simulation
The programming on each media slot can be simulated for each of the pixel matrices on which the media slot was
used in Pharos Designer.

Selecting a Pixel Matrix
The current pixel matrix number is displayed on the application toolbar, along with the total number of pixel matrices
on which the selected media slot is used. Use the arrow buttons to change the current pixel matrix.

Adjusting the Simulation View
l

Zoom In: click

l

Zoom Out: click
Pan: click and drag to pan the simulation view, or use the scroll bars.

l
l
l

Show Used Pixels: click
to enable this feature. Click
again to disable.
Background Colour: this can be changed in the Preferences dialog.

Simulation Playback
Use the simulation playback buttons on the application toolbar.
l

Play:

l

Pause:

l

Stop:

l

Seek Forwards:

l

Seek Backwards:

The current point in time for the simulation is shown on the application toolbar.
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Export

Export
Pharos Dynamic Media Manager exports media slot programming in a format suitable for transferring to Pharos Controllers. Click

. You will be prompted for a folder to save the generated files.

A successful export will place a folder in the location you have chosen for each Designer project in your Dynamic
Media Manager project. Each folder will be named the same as the Designer project followed by the unique Designer
project ID number surrounded by {} brackets. These folders will contain additional folders, one per Controller in the
Designer project - it is inside each Controller’s folder that the Media Slot information is stored, ready to be uploaded.

Dynamic Media Manager will only generate media for Controllers that were patched in the associated Designer
project. In addition, one or more media slots must be programmed onto timelines. You can make changes to your
Designer project at any time and then update this information in Dynamic Media Manager by importing a new
.pmm file (exported from Designer) into your existing Dynamic Media Manager project.
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Uploading Slots
After you have exported your Dynamic Media Manager slot programming, you now must move these files to each
Controller so that your timelines can use the new slot programming. There are two ways to do this:

Pharos Installation Manager
Provided your Controllers are connected to a network and accessible from your computer, the Pharos Installation
Manager application, free to download from our website, can easily transfer both your Designer project file and media
slot information to each Controller. Please refer to the Installation Manager help for how to setup and start using this
application.

FTP Transfer
Provided your Controllers are connected to a network and accessible from your computer, any FTP application can
connect to a Controller and allow you to move the media slot files for each Controller to the Controller’s memory
card.
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Preferences

Preferences
Click the down arrow next to the Help button on the main toolbar then click

to open the Preferences dialog.

Simulation
Set preferences for how media slot programming is simulated.

Background Colour
Set the background colour of the simulation view. If you have media that's predominantly white then it may be helpful
to change the background colour from the default.

Background Lines
Choose whether diagonal lines are displayed on the simulation view as a contrast aid and what their colour is.

Software Update
Choose whether Pharos Dynamic Media Manager checks for new beta versions as well as new releases.

- 21 -

Pharos Dynamic Media Manager User Manual

Frequently asked questions
Is the free software a cut-down demo version?
No. The free Dynamic Media Manager software is the full software package. Downloads and updates can be found
on our website.

Does the Dynamic Media Manager software support the Apple Macintosh?
Yes, from v1.0 we have full support for Intel Macs running Apple OS X 10.5 and later. Project files will be compatible,
regardless of the operating system on which they are created.

What are the PC minimum requirements for Dynamic Media Manager?
l
l
l
l
l

Microsoft Windows XP (SP2+ 32bit only), Vista (32/64bit) & 7 (32/64bit)
Intel processor at 1 GHz or above
256MB RAM
100MB free hard disk space
800x600 minimum screen resolution (higher is better)

What are the minimum Macintosh requirements for Dynamic Media Manager?
l
l
l
l
l

Apple Mac OS X 10.5.x or later (32bit only)
Intel processor at 1 GHz or above
256MB RAM
100MB free hard disk space
800x600 minimum screen resolution (higher is better)

Are project files compatible across versions and platforms?
Any project file saved in an earlier version of Dynamic Media Manager can be loaded by a later version. Project files
are compatible between the PC and Mac versions of the software. However, projects saved in a later version of
Dynamic Media Manager may not be backwards compatible with an earlier version as we reserve the right to make
structural changes to improve the product.

Can I have multiple versions of Dynamic Media Manager on my computer?
Yes, as long as you install the software to a different location each time. However, this could lead to confusion and a
reinstall takes just seconds, so we would recommend keeping the installers on hand and only having one version
installed at a time.

How many media slots can I import? How many media presets can I create,
etc?
See system limits and capacities.

What are the Pharos Dynamic Media Manager file extensions?
*.dmm

Pharos Dynamic Media Manager project file.

*.pmm

Generated by Pharos Designer from the File menu, it contains information about the media slots,
the pixel matrices and the patch for importing into Dynamic Media Manager.
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Frequently asked questions

How do I add media slots to my Pharos Dynamic Media Manager project?
Media slots are added to a Pharos Dynamic Media Manager project when you import a .pmm file that was generated
by Pharos Designer. Media slots in Dynamic Media Manager represent media slots in a Designer project.

What if I make changes to my Designer project?
If you make any changes to your Designer project after you've already created programming for your media slots in
Dynamic Media Manager then you can simply import the changes into your existingDynamic Media Manager project.
In Designer, go to File > Export for Media Manager to generate the .pmm file again, then click the Import button in
Dynamic Media Manager and select this file. The media slots will be updated.
The only changes to a Designer project that will affect Dynamic Media Manager are changes to the patch, pixel
matrices, media slots and the programming of media slots on timelines. If you make any other changes you do not
need to update your Dynamic Media Manager project.
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Troubleshooting
The following section lists common problems and their solutions.

I've exported my Dynamic Media Manager project but there are no files in the
folders for each Controller?
The fixtures in the pixel matrices in your Designer project must be patched before Dynamic Media Manager can
know which files to generate for which Controller. Open your Designer project, complete the patch and then go to
File > Export for media manager to generate the .pmm file again. Return to Dynamic Media Manager and import this
.pmm file into your existing Dynamic Media Manager project. Your media slots will be updated with the new patch
information and you can click the Export button to generate files for your Controllers.

I have checked the FAQ and troubleshooting but I'm still stuck?
Contact support, please be prepared to send in your project files.

- 24 -

Media Slot Anatomy

Media Slot Anatomy
The media slots that you create in Pharos Designer have three user-modifiable time elements: the slot Length, Fade
in time and Release time. Adjusting these parameters will affect the output of media slots. Some applications may
require fixed fade times for all slot content while others may want to have these times flexible and set via Dynamic
Media Manager. Each scenario is discussed below:

Typical Slot Usage
When a media slot is created in Designer you select an overall Length. When the same media slot is added to a timeline you can add Fade in and Release timing as with any preset. Close attention should be paid to these time settings as you begin to add media to your slots in Dynamic Media Manager.
Below is a graphical example of a 10 second media slot that has been given a 2 second fade in and a 2 second
release time. Notice that the release time occurs after the slot duration has been reached - you should always place
enough media on a slot to cover the duration & release time.

For example, you could add a 6 second video followed by a 6 second 2D Matrix preset. The two clips total 12 seconds, equalling the duration plus the release time of the slot. When this slot is played on an LPC the media will start
immediately but full brightness won’t be achieved until the 2 second fade completes. When the duration of 10 seconds has been reached the slot’s 2 second release will begin and complete at the 12 second mark.
Note: the transition between the effects is set in Dynamic Media Manager and will output as simulated.

Note: Filling a slot completely provides the best playback results when media slots interact with other timeline elements.

Alternate Slot Usage
Another approach is to allow Dynamic Media Manager to govern all fade and release timing. When adding a media
slot to a timeline, set both fade and release times to 0 seconds. This allows you to customize the fades when placing
media on the slots within Dynamic Media Manager. The example below offers similar playback as the example
above, except the fade in and release times are set in Dynamic Media Manager. During playback, fade and release
timings happen within the confines of the slot’s duration. The only drawback to this approach is that the transition to
another timeline element will snap through black, rather than crossfading.
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Note: Using fade times on both the slot and the DMM media is not recommended and can create some
unexpected transitions.

Looping and Cropping
Because media slots have a fixed duration, the question arises about how a slot will function if you place too much
media on it or not enough. Study the examples below to be sure you get what you expect when adding media onto
your slots.

Media longer than the slot:

In fig.1 when 10 seconds is reached the video immediately stops playback or takes the slot’s release time if set
above 0. The last 2 seconds of the 14 second video is never seen.

Media does not fill the entire slot:

In fig. 2, a 3.5 second video clip is placed on a 10 second slot with a 2 second fade in and release. During playback
the media slot will attempt to fill itself with content and therefore loop the 3.5 second clip until the total duration of the
slot is reached.
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Media Slot Anatomy

This example, fig.3 is very similar to fig. 2 above except the slot does not contain a fade or release time. Instead the
4 second media clip contains the fade and release times as set within Dynamic Media Manager. During playback,
the looping nature of the short clip is as above except the fade and release are executed on every loop. The slot
bumps the clip out abruptly when the slot’s duration is reached.
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Software limits & capacities
Pharos Dynamic Media Manager imposes the following project limits which cannot be exceeded:
Media slots

1024

Pixel matrices

2560

Media presets

256

Designer projects

10

The number of different .pmm files that can be imported
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