We’ve added the ability to import and export your timeline flags in Designer 2.11. This feature unlocks new possibilities for programming your project, allowing you to integrate your Designer programming workflow with your favourite software tools for audio editing, video production and more.
Flags can be placed throughout timelines in Designer and are useful for keeping track of important moments in your lighting programming. Each flag acts as a waypoint, recording a position on your timeline along with a customisable name for easy identification. Using our timeline flag trigger, flags can be used to fire triggers which activate lighting events and other actions on your Pharos controller. Find out more about the wide range of triggering possibilities available in Designer.
If you’re creating a soundtrack for your lighting installation with flags or markers in a 3rd party digital audio workstation such as Reaper or Avid Pro Tools, you can now import those markers straight into your Designer timeline and use them to synchronise your lighting playback to your soundtrack.
Similarly, if you’ve already perfected your light show in Designer and now need to create video content which lines up with the same important moments in your show, you can export timeline flags from Designer and import them into your favourite video editing suites such as DaVinci Resolve and Adobe Premier Pro.
How to export timeline flags from Designer

With your project file open in Designer, navigate to the Timeline tab and ensure your timeline flags are placed correctly. If you’re not sure how to get started, our online help pages contain more information on using flags in timelines.
Once your timeline is set up, navigate to the main menu in the top right corner of Designer and select ‘Export Object…’


On the following screen, select ‘Timeline Flags’ and follow the steps presented. You will be asked to specify the timeline from which you would like to export flags and where the exported file should be saved. Timeline flags are exported in CSV format.
How to import timeline flags to Designer
Navigate to the main menu in the top right corner of Designer and select ‘Import Object…’



From here, select ‘Timeline Flags’ and specify the location of the file you wish to import. Follow the instructions as the helper guides you through associating which columns in your imported file correspond to flag name and flag time. If the file you’re importing contains additional columns, set these to ‘Ignore’.
Click ‘Next’ and then ‘Finish’ to create a new timeline with your new flags positioned in the correct locations.

Importing markers into Designer from other software packages
The steps below explain the process of exporting markers from popular software packages so that they can be imported into Designer. We have included steps for Adobe Premier Pro, DaVinci Resolve and Reaper, but many other software packages allow timeline markers to be exported in a CSV or text file format compatible with Designer.
Export markers from Adobe Premier Pro and import into Designer
In Adobe Premier Pro, select File → Export → Markers and specify an output destination for the file.


You can now follow the steps explained earlier in this article to import your Adobe Premier markers as flags in your Designer timeline.
Export markers from DaVinci Resolve and import into Designer
In DaVinci Resolve, select ‘Index’ at the top of the screen to reveal the Edit Index tab. From here, click the three dots and select ‘Export Edit Index’. Finally, select a location to save the generated CSV file.

You can now follow the steps explained earlier in this article to import your DaVinci Resolve markers as flags in your Designer timeline.
Export markers from Reaper and import into Designer
In Reaper, navigate to View → Region/Marker Manager and select Options → Export regions/markers… From here, select a location to save the generated CSV file.

You can now follow the steps explained earlier in this article to import your Reaper Resolve markers as flags in your Designer timeline.

